
<!DOCTYPE html>
<!--[if lt IE 9]><html lang="en-US" class="oldie"><![endif]-->
<!--[if (gte IE 9) | !(IE)]><!--><html lang="en-US" class="modern"><!--<![endif]-->
<head>
<meta name="google-site-verification" content="dlSibRSx_DaroIP1mbXfRkvZI5ynRPiUu6vyjE-bWEA" />
<meta charset="UTF-8" />
<title>How to Effectively Manage Time Better | </title>

<!-- Always force latest IE rendering engine & Chrome Frame -->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />

<!-- Meta Viewport -->
<meta name="viewport" content="width=device-width, initial-scale=1" />

<link rel="shortcut icon" href="http://www.snowcollegenews.com/wp-content/uploads/2013/10/favicon1.ico" />
<link rel="apple-touch-icon-precomposed" href="http://www.snowcollegenews.com/wp-content/themes/simplemag/images/retina-favicon.png" />

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://www.snowcollegenews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="http://www.snowcollegenews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; How to Effectively Manage Time Better Comments Feed" href="http://www.snowcollegenews.com/how-to-effectively-manage-time-better/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.snowcollegenews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ai1ec_style-css'  href='//www.snowcollegenews.com/wp-content/plugins/all-in-one-event-calendar/cache/b14081cd_ai1ec_parsed_css.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.snowcollegenews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='framework-css'  href='http://www.snowcollegenews.com/wp-content/themes/simplemag/css/framework.css?ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='icons-css'  href='http://www.snowcollegenews.com/wp-content/themes/simplemag/css/icons.css?ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css'  href='http://www.snowcollegenews.com/wp-content/themes/simplemag/style.css?ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='http://fonts.googleapis.com/css?subset=latin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext&#038;family=Abel%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C900%2C900italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C700%2C700italic%2C900%2C900italic+rel%3D%27stylesheet%27+type%3D%27text%2Fcss&#038;ver=5.3.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.snowcollegenews.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.9.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/plugins/wp-captcha-booster/assets/global/plugins/custom/js/front-end-script.js?ver=5.3.6'></script>
<link rel='https://api.w.org/' href='http://www.snowcollegenews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.snowcollegenews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.snowcollegenews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Badger Volleyball Season Schedule Announced' href='http://www.snowcollegenews.com/badger-volleyball-season-schedule-announced/' />
<link rel='next' title='New Year&#8217;s Resolutions, How to Keep Them' href='http://www.snowcollegenews.com/new-years-resolutions-how-to-keep-them/' />
<meta name="generator" content="WordPress 5.3.6" />
<link rel="canonical" href="http://www.snowcollegenews.com/how-to-effectively-manage-time-better/" />
<link rel='shortlink' href='http://www.snowcollegenews.com/?p=7075' />
<link rel="alternate" type="application/json+oembed" href="http://www.snowcollegenews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.snowcollegenews.com%2Fhow-to-effectively-manage-time-better%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.snowcollegenews.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.snowcollegenews.com%2Fhow-to-effectively-manage-time-better%2F&#038;format=xml" />
<style>
/* Theme Options Styling */
body {font-family:'Abel', Arial, Verdana, 'Helvetica Neue', Helvetica, sans-serif;}
h1, h2, h3, h4, h5, h6, .tagline, .sub-title, .menu a, .widget_pages, .widget_categories, .entry-meta, .entry-note, .read-more, #submit, .single .entry-content > p:first-of-type:first-letter, input#s, .widget_ti-about-site p, .comments .vcard, #respond label, .copyright, #wp-calendar tbody, .latest-reviews i, .score-box .total {font-family: 'Oswald', Arial, Verdana, 'Helvetica Neue', Helvetica, sans-serif; font-weight:400;}
.sub-menu ul li a:hover, .secondary-menu a:hover, .secondary-menu .current_page_item > a, .top-strip nav > ul > li:hover > a, .footer-sidebar .widget h3 {color:#ea8304 !important;}
#masthead .main-menu > ul > li.sub-hover > a:after{border-color:transparent transparent #ea8304;}
#masthead .main-menu > ul > li{font-size:16px;}
#masthead .main-menu .sub-menu{border-top-color:#ea8304;}
.widget_ti_most_commented span i:after{border-top-color:#ea8304;border-left-color:#ea8304;}
.entry-image, .page-numbers .current, .link-pages span, .score-line span, .widget_ti_most_commented span {background-color:#ea8304;}
::selection {background-color:#ea8304;}
::-moz-selection {background-color:#ea8304;}
</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Effectively Manage Time Better" />
<meta property="og:url" content="http://www.snowcollegenews.com/how-to-effectively-manage-time-better/" />
<meta property="og:description" content="The life of a college student is full of adventure. From classes, to work, to social events, &nbsp; sometimes it can be hard to have time for everything. Here are some time management tips.&nbsp; T…" />
<meta property="article:published_time" content="2021-02-09T21:10:57+00:00" />
<meta property="article:modified_time" content="2021-02-16T21:13:34+00:00" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="How to Effectively Manage Time Better" />
<meta name="twitter:card" content="summary" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="post-template-default single single-post postid-7075 single-format-standard">

<div id="outer-wrap">
    <div id="inner-wrap">

    <div id="pageslide">
        <a id="close-pageslide" href="#top"><i class="icon-remove-sign"></i></a>
    </div><!-- Sidebar in Mobile View -->

    <header id="masthead" role="banner" class="clearfix">
        
		<div class="top-strip color-site-white">
            <div class="wrapper clearfix">
            	
                
<form method="get" id="searchform" action="http://www.snowcollegenews.com/" role="search">
	<input type="text" name="s" id="s" value="Search" onfocus="if(this.value=='Search')this.value='';" onblur="if(this.value=='')this.value='Search';" />
    <button type="submit">
    	<i class="icon-search"></i>
    </button>
</form>                
                <ul class="social"><li><a href="https://www.facebook.com/pages/Snowdrift/532921896799164" class="icon-facebook" target="_blank"></a></li><li><a href="https://twitter.com/SnowCollegeNews" class="icon-twitter" target="_blank"></a></li></ul>                
                <a id="open-pageslide" href="#pageslide"><i class="icon-menu"></i></a>
                
                <nav class="secondary-menu"><ul id="secondary-nav" class="menu"><li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60"><a href="http://www.snowcollegenews.com/home-2/">Home</a></li>
<li id="menu-item-61" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61"><a href="http://www.snowcollegenews.com/about-us/">About</a></li>
<li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59"><a href="http://www.snowcollegenews.com/contact/">Contact</a></li>
<li id="menu-item-58" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58"><a href="http://www.snowcollegenews.com/archives/">Archives</a></li>
</ul></nav>            </div><!-- .wrapper -->
        </div><!-- .top-strip -->
        
        
        <div class="wrapper">
        	
            <div id="branding" class="animated">
                <!-- Logo -->
				                <a class="logo" href="http://www.snowcollegenews.com/">
                    <img src="http://www.snowcollegenews.com/wp-content/uploads/2013/10/Snowdrift-masthead-2Blue1.png" alt=" - " title=" - " />
                </a>
                <!-- End Logo -->
                
                            </div>
            
            <nav class="animated main-menu"><ul id="main-nav" class="menu"><li id="menu-item-85" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/campus/">Campus News</a><div class="sub-menu"></div>
</li>
<li id="menu-item-79" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/student-life/">Student Life</a><div class="sub-menu"></div>
</li>
<li id="menu-item-82" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/in-the-news/">In the News</a><div class="sub-menu"></div>
</li>
<li id="menu-item-80" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/sports/">Sports</a><div class="sub-menu"></div>
</li>
<li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/entertainment/">Entertainment</a><div class="sub-menu"></div>
</li>
<li id="menu-item-81" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/opinion/">Opinion</a><div class="sub-menu"></div>
</li>
<li id="menu-item-6954" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.snowcollegenews.com/home-2/">Home</a><div class="sub-menu"></div>
</li>
</ul></nav>    
        </div><!-- .wrapper -->     
    </header><!-- #masthead -->		
    <section id="content" role="main" class="clearfix animated">

	           
      <article id="post-7075" class="post-7075 post type-post status-publish format-standard hentry category-opinion category-student-life">
      
        <header class="entry-header wrapper">
        
            <div class="entry-meta">
			                  <span class="entry-author">
                    By <a href="http://www.snowcollegenews.com/author/taya-baker/" rel="author">Taya Baker</a>
               </span>
                              <span class="entry-category"><a href="http://www.snowcollegenews.com/category/opinion/" >Opinion</a>, <a href="http://www.snowcollegenews.com/category/student-life/" >Student Life</a></span>
               <span class="entry-date">February 9, 2021</span>
            </div>
            
            <h1 class="entry-title single-title">
                <span>How to Effectively Manage Time Better</span>
            </h1>
            
        </header>
        
        
		        	<div class="entry-media">
            	
            </div>
                
        
        <div class="wrapper">
			            <div class="grids">
                <div class="grid-8">
                            
                
                               <div class="single-box entry-media">
                                    </div>
                             
               
			               
            
                <div class="single-box clearfix entry-content">
                	<div id="fsb-social-bar" class="fsb-social-bar" data-post-id="7075" data-socialite="true"><style type="text/css">            #fsb-social-bar { width: 100%; border-bottom: 1px solid #dbdbdb; border-top: 1px solid #dbdbdb; padding: 10px 0; margin: 0px 0 20px 0; float: left; background: #fff; position: relative; clear: both; }            #fsb-social-bar a { border: 0px !important }            #fsb-social-bar.fsb-fixed { position: fixed; top: -2px; z-index: 99999; }            #fsb-social-bar .fsb-title { display: block; float: left; margin: 3px 20px 0 0; font-size: 16px; font-family: Arial, Helvetica, sans-serif; text-decoration: none; color: #333; }            #fsb-social-bar .fsb-share-facebook { width: 120px; float: left; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-facebook.fsb-hide-count { width: 44px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-twitter { float: left; width: 135px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-twitter.fsb-hide-count { width: 61px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-google { float: left; width: 105px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-google.fsb-hide-count { width: 33px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-linkedin { float: left; width: 135px; padding: 3px 0 2px; height: 25px; }            #fsb-social-bar .fsb-share-linkedin.fsb-hide-count { width: 61px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .fsb-share-pinterest { float: left; width: 115px; padding: 3px 0 2px; height: 25px;}            #fsb-social-bar .fsb-share-pinterest.fsb-hide-count { width: 43px; overflow: hidden; margin-right: 30px; }            #fsb-social-bar .socialite { display: block; position: relative; background: url(http://www.snowcollegenews.com/wp-content/plugins/floating-social-bar/images/fsb-sprite.png) no-repeat scroll 0 0; }            #fsb-social-bar .socialite-loaded { background: none !important; }            #fsb-social-bar .fsb-service-title { display: none; }            #fsb-social-bar a { color: #333; text-decoration: none; font-size: 12px; font-family: Arial, Helvetica, sans-serif; }            #fsb-social-bar .fsb-twitter { width: 105px; height: 25px; background-position: -13px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-twitter .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 69px; color: #333; }            #fsb-social-bar .fsb-google { width: 75px; height: 25px; background-position: -136px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-google .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 41px; color: #333; }            #fsb-social-bar .fsb-google .socialite-button { margin: 0 !important; }            #fsb-social-bar .fsb-share-google .socialite-loaded .socialite-button{padding: 2px 0 0}            #fsb-social-bar .fsb-facebook { width: 89px; height: 25px; background-position: -231px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-facebook .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 52px; color: #333; }            #fsb-social-bar .fsb-facebook .socialite-button { margin: 0 !important;}            #fsb-social-bar .fsb-share-facebook .socialite-loaded .socialite-button {padding: 2px 0 0}            #fsb-social-bar .fsb-linkedin { width: 105px; height: 25px; background-position: -347px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-linkedin .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 70px; color: #333; }            #fsb-social-bar .fsb-linkedin .socialite-button { margin: 0 !important; }            #fsb-social-bar .fsb-pinterest { width: 88px; height: 25px; background-position: -484px -10px; line-height: 25px; vertical-align: middle; }            #fsb-social-bar .fsb-pinterest .fsb-count { width: 30px; text-align: center; display: inline-block; margin: 0px 0 0 50px; color: #333; }            #fsb-social-bar .fsb-pinterest .socialite-button { margin: 0 !important; }            .fsb-clear { clear: both; }            .fsb-clear:after { clear:both; content:; display:block; height:0; line-height:0; overflow:auto; visibility:hidden; zoom:1; }            @media (max-width: 768px) { #fsb-social-bar.fsb-fixed { position: relative !important; top: auto !important; } }        </style><span class="fsb-title">Don&#039;t forget to like and share! 🙂</span><div class="fsb-share-facebook fsb-hide-count"><a href="http://www.facebook.com/sharer.php?u=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/" class="socialite facebook fsb-facebook" data-fsb-service="facebook" data-href="http://www.snowcollegenews.com/how-to-effectively-manage-time-better/" data-send="false" data-layout="button_count" data-width="60" data-show-faces="false" rel="nofollow" target="_blank"><span class="fsb-service-title">Facebook</span><span class="fsb-count">0</span></a></div><div class="fsb-share-twitter fsb-hide-count"><a href="https://twitter.com/share?original_referer=http%3A%2F%2Fwww.snowcollegenews.com%2F&source=tweetbutton&text=How+to+Effectively+Manage+Time+Better&url=http%3A%2F%2Fwww.snowcollegenews.com%2Fhow-to-effectively-manage-time-better%2F&via=SnowCollegeNews" class="socialite twitter fsb-twitter" data-fsb-service="twitter" rel="nofollow" target="_blank" title="Be the first one to tweet this article!"><span class="fsb-service-title">Twitter</span><span class="fsb-count">0</span></a></div></div><div class="fsb-clear"></div>
<p>The life of a college student is full of adventure. From classes, to work, to social events, &nbsp; sometimes it can be hard to have time for everything. Here are some time management tips.&nbsp;</p>



<p>The first thing to try when organizing a busy schedule is determining where the priorities lie. What matters the most today? Mckenna Johnson a student at Snow College said, “I definitely think it’s hard to time manage! One thing that really helps me is writing everything I need to do in my planner and then checking things off as I go.”  </p>



<p>A good way to determine what is most important is to use the A, B, C system.  A level  priorities are the activities that are the most urgent.  B level  priorities include tasks that are not urgent yet but will be soon. C level priorities are tasks that are not urgent but are still on the to do list.  Then complete the tasks in order from A-C.   </p>



<p>The second tip  is to do the time consuming and taxing tasks first. This may sound counterintuitive at first, the goal is to accomplish more not less. Well in the long run doing the hard things first clears up to do lists faster than doing the little things first.  How? People are the most energized when starting activities on a to-do list.  Therefore, it&#8217;s important to put the heavy things at the top of the list in order to spend the majority of energy on the taxing things instead of the easy things.  Try these tips out next time the to-do list is long!</p>
<div id="author-bio-box" style="background: #f8f8f8; border-top: 2px solid #cccccc; border-bottom: 2px solid #cccccc; color: #333333"><h3><a style="color: #555555;" href="http://www.snowcollegenews.com/author/taya-baker/" title="All posts by Taya Baker" rel="author">Taya Baker</a></h3><div class="bio-gravatar"><img alt='' src='http://0.gravatar.com/avatar/06ff94b728ba843ca32a928b90e3d4d2?s=70&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/06ff94b728ba843ca32a928b90e3d4d2?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /></div><p class="bio-description"></p></div>                                    </div>
                
                
                                
                                
                                
                
                                <div id="social-box" class="single-box clearfix">
                    <ul>
                        <li>
                            <span>Share on:</span>
                        </li>
                        <li>
                            <a href="http://www.facebook.com/sharer.php?u=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/&amp;t=How to Effectively Manage Time Better" target="blank">Facebook</a>
                        </li>
                        <li>
                            <a href="https://twitter.com/intent/tweet?original_referer=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/&amp;text=How to Effectively Manage Time Better&tw_p=tweetbutton&url=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/&via=" target="_blank">Twitter</a>
                        </li>
                        <li>
                                                        <a href="//pinterest.com/pin/create/button/?url=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/&amp;media=&amp;description=How to Effectively Manage Time Better" target="_blank">Pinterest</a>
                        </li>
                        <li>
                            <a href="https://plusone.google.com/_/+1/confirm?hl=en-US&amp;url=http://www.snowcollegenews.com/how-to-effectively-manage-time-better/" target="_blank">Google +</a>
                        </li>
                    </ul>
                </div><!-- social-box -->
                                
                
                                
				
                				<nav class="single-box clearfix nav-single">
                                        <div class="nav-previous">
                    	<a href="http://www.snowcollegenews.com/badger-volleyball-season-schedule-announced/" rel="prev"><i class="icon-chevron-left"></i><span class="sub-title">Previous article</span><br />Badger Volleyball Season Schedule Announced</a>                    </div>
                                        
                                        <span class="sep"></span>
                     
                    
                                        <div class="nav-next">
                        <a href="http://www.snowcollegenews.com/new-years-resolutions-how-to-keep-them/" rel="next"><i class="icon-chevron-right"></i><span class="sub-title">Next article</span><br />New Year&#8217;s Resolutions, How to Keep Them</a>                    </div>
                                    </nav><!-- .nav-single -->
				                
                
                
	<div class="single-box related-posts">
        <h3 class="entry-title">
            You may also like        </h3>
	
        <div class="grids entries">
        	<div class="carousel">
            
			    
			<article class="grid-4 post-7025 post type-post status-publish format-standard hentry category-opinion category-student-life tag-204 tag-new-years tag-resolution">
								  
                  <figure class="entry-image">
                  
                      <a href="http://www.snowcollegenews.com/new-years-resolutions-how-to-keep-them/">
						                        </a>
                      
                                    
                  </figure>
                  
                  <header class="entry-header">
                      <div class="entry-meta">
                         <span class="entry-date">February 9, 2021</span>
                      </div>
                      <h2 class="entry-title">
                          <a href="http://www.snowcollegenews.com/new-years-resolutions-how-to-keep-them/">New Year&#8217;s Resolutions, How to Keep Them</a>
                      </h2>
                  </header>
                  
              </article>
        
    		    
			<article class="grid-4 post-7066 post type-post status-publish format-standard hentry category-entertainment category-opinion category-student-life tag-books tag-romance">
								  
                  <figure class="entry-image">
                  
                      <a href="http://www.snowcollegenews.com/5-romance-novels-to-read/">
						                        </a>
                      
                                    
                  </figure>
                  
                  <header class="entry-header">
                      <div class="entry-meta">
                         <span class="entry-date">February 9, 2021</span>
                      </div>
                      <h2 class="entry-title">
                          <a href="http://www.snowcollegenews.com/5-romance-novels-to-read/">5 Romance Novels to Read</a>
                      </h2>
                  </header>
                  
              </article>
        
    					
            </div>
         </div>
         <a class="prev carousel-nav" href="#"><i class="icon-chevron-right"></i></a>
		 <a class="next carousel-nav" href="#"><i class="icon-chevron-left"></i></a>
         
	</div><!-- .single-box .related-posts -->
    
                
                
                


			
	


		<div id="respond" class="single-box">
		
            <h3 class="entry-title">
            
				
                					Be first to comment                                
                <span class="cancel_reply">
                    <a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-effectively-manage-time-better/#respond" style="display:none;">Click here to cancel reply.</a>                </span>
            
            </h3>
			
            	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-effectively-manage-time-better/#respond" style="display:none;">Cancel reply</a></small></h3><form action="http://www.snowcollegenews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="cptch_block">Solve : <span style='color:red'>*</span> <br>30 &times; 14 =  <input id="cptch_input" class="cptch_input" type="text" autocomplete="off" name="ux_txt_captcha_input" value="" maxlength="5" size="2" aria-required="true" onkeypress="validate_digits_frontend_captcha_booster(event);"  style="margin-bottom:0;display:inline;font-size: 12px;width: 40px;" /><input type="hidden" name="captcha_booster_result" value="A6e0vw==" />
			<input type="hidden" name="captcha_booster_time" value="1613611530" />
			<input type="hidden" value="Version: " /></p><br /><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='7075' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3ae9329653" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="115"/></p></form>	</div><!-- #respond -->
			
						
		</div>
	                
        
				                    </div><!-- .grid-8 -->
                
                    <div class="grid-4">
                        
    <aside class="sidebar sidebar-mobile" role="complementary">
	<div id="ti_latest_posts-2" class="widget widget_ti_latest_posts"><h3>Newest Articles</h3>            
                        
            <div class="flexslider">
                <ul class="slides">
                                        
                    <li>                                                           
                            <figure class="entry-image">
                                <a href="http://www.snowcollegenews.com/snow-blasts-gone/">
                                    <img src="https://www.snowcollegenews.com/wp-content/uploads/2021/02/Ambassedors-.jpg" class="attachment-masonry-size wp-post-image" />                                </a>
                            </figure>
                            
                            <h2 class="entry-title">
                                <a href="http://www.snowcollegenews.com/snow-blasts-gone/">Snow Blasts Gone?</a>
                            </h2>
                            
                        </li>                    
                                        
                    <li>                                                           
                            <figure class="entry-image">
                                <a href="http://www.snowcollegenews.com/groundhog-sees-shadow/">
                                    <img src="https://www.snowcollegenews.com/wp-content/uploads/2021/02/the-Philadelphia-inquirer--1024x682.jpg" class="attachment-masonry-size wp-post-image" />                                </a>
                            </figure>
                            
                            <h2 class="entry-title">
                                <a href="http://www.snowcollegenews.com/groundhog-sees-shadow/">Groundhog Sees Shadow</a>
                            </h2>
                            
                        </li>                    
                                        
                    <li>                                                           
                            <figure class="entry-image">
                                <a href="http://www.snowcollegenews.com/a-history-of-presidents-day/">
                                    <img src="https://www.snowcollegenews.com/wp-content/uploads/2021/02/presidents-day.jpg" class="attachment-masonry-size wp-post-image" />                                </a>
                            </figure>
                            
                            <h2 class="entry-title">
                                <a href="http://www.snowcollegenews.com/a-history-of-presidents-day/">A History of President’s Day</a>
                            </h2>
                            
                        </li>                    
                                        
                    <li>                                                           
                            <figure class="entry-image">
                                <a href="http://www.snowcollegenews.com/becky-adams-awarded-employee-of-the-semester/">
                                    <img src="https://www.snowcollegenews.com/wp-content/uploads/2021/02/wvjKyGrjNQG1dX9p.jpg" class="attachment-masonry-size wp-post-image" />                                </a>
                            </figure>
                            
                            <h2 class="entry-title">
                                <a href="http://www.snowcollegenews.com/becky-adams-awarded-employee-of-the-semester/">Becky Adams Awarded Employee Of The Semester</a>
                            </h2>
                            
                        </li>                    
                                        
                    <li>                                                           
                            <figure class="entry-image">
                                <a href="http://www.snowcollegenews.com/the-man-with-a-deep-voice-corpse-husband/">
                                                                    </a>
                            </figure>
                            
                            <h2 class="entry-title">
                                <a href="http://www.snowcollegenews.com/the-man-with-a-deep-voice-corpse-husband/">The Man With a Deep Voice: Corpse Husband</a>
                            </h2>
                            
                        </li>                    
                                        
                </ul>            </div>
			
			            
			
	    </div><div id="ti_featured_posts-5" class="widget widget_ti_featured_posts"><h3>Featured Posts</h3>            
            			<div class="flexslider">
            
				<ul class="slides">
								
					<li class="post-6994 post type-post status-publish format-standard hentry category-student-life">
                                                       
                        <figure class="entry-image">
                            <a href="http://www.snowcollegenews.com/badgers-thanksgiving-traditions/">
                                                            </a>
                        </figure>
						
						<h2 class="entry-title">
							<a href="http://www.snowcollegenews.com/badgers-thanksgiving-traditions/">Badgers Thanksgiving Traditions</a>
						</h2>
						
					</li>
					
								
					<li class="post-6998 post type-post status-publish format-standard hentry category-student-life">
                                                       
                        <figure class="entry-image">
                            <a href="http://www.snowcollegenews.com/where-does-the-origin-of-eating-turkey-for-thanksgiving-come-from/">
                                                            </a>
                        </figure>
						
						<h2 class="entry-title">
							<a href="http://www.snowcollegenews.com/where-does-the-origin-of-eating-turkey-for-thanksgiving-come-from/">Where Does the Origin of Eating Turkey For Thanksgiving Come From?</a>
						</h2>
						
					</li>
					
								
					<li class="post-7011 post type-post status-publish format-standard hentry category-student-life">
                                                       
                        <figure class="entry-image">
                            <a href="http://www.snowcollegenews.com/thanksgiving-break-are-students-coming-back/">
                                                            </a>
                        </figure>
						
						<h2 class="entry-title">
							<a href="http://www.snowcollegenews.com/thanksgiving-break-are-students-coming-back/">Thanksgiving Break: Are Students Coming Back?</a>
						</h2>
						
					</li>
					
								
					<li class="post-6958 post type-post status-publish format-standard has-post-thumbnail hentry category-student-life tag-activities tag-snowcollege tag-studentlife tag-students">
                                                       
                        <figure class="entry-image">
                            <a href="http://www.snowcollegenews.com/memories-of-snow-college-looked-back-upon/">
                                <img width="600" height="400" src="https://www.snowcollegenews.com/wp-content/uploads/2020/04/IMG_9301-600x400.jpeg" class="attachment-medium-size size-medium-size wp-post-image" alt="" srcset="https://www.snowcollegenews.com/wp-content/uploads/2020/04/IMG_9301-600x400.jpeg 600w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/IMG_9301-296x197.jpeg 296w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/IMG_9301-1050x700.jpeg 1050w" sizes="(max-width: 600px) 100vw, 600px" />                            </a>
                        </figure>
						
						<h2 class="entry-title">
							<a href="http://www.snowcollegenews.com/memories-of-snow-college-looked-back-upon/">Memories of Snow College Looked Back Upon</a>
						</h2>
						
					</li>
					
								
					<li class="post-6975 post type-post status-publish format-standard has-post-thumbnail hentry category-in-the-news tag-snowcollege tag-students tag-tuition">
                                                       
                        <figure class="entry-image">
                            <a href="http://www.snowcollegenews.com/student-argue-for-free-passes-and-refunds-after-snow-college-latest-changes/">
                                <img width="600" height="400" src="https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-600x400.jpg" class="attachment-medium-size size-medium-size wp-post-image" alt="" srcset="https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-600x401.jpg 600w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-300x200.jpg 300w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-1024x684.jpg 1024w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-768x513.jpg 768w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-1536x1026.jpg 1536w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-2048x1368.jpg 2048w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-296x197.jpg 296w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-1050x700.jpg 1050w, https://www.snowcollegenews.com/wp-content/uploads/2020/04/online-education-868x580.jpg 868w" sizes="(max-width: 600px) 100vw, 600px" />                            </a>
                        </figure>
						
						<h2 class="entry-title">
							<a href="http://www.snowcollegenews.com/student-argue-for-free-passes-and-refunds-after-snow-college-latest-changes/">Student Argue for Free Passes and Refunds after Snow College Latest Changes</a>
						</h2>
						
					</li>
					
								</ul>
                
			</div>
			
			
	    </div>    </aside><!-- .sidebar -->                    </div>
                </div><!-- .grids -->
                            
            </div><!-- .wrapper -->
        </article>
              
        
    </section><!-- #content -->
    
        

    <footer id="footer" role="contentinfo" class="animated color-site-white">
    
        

    <div class="footer-sidebar">
            <div id="supplementary" class="wrapper clearfix columns col-3">
                                <div id="first" class="widget-area" role="complementary">
                    <div id="ti-about-site-3" class="widget widget_ti-about-site"><h3>About</h3><img src="http://www.snowcollegenews.com/wp-content/uploads/2013/10/seal.png" alt="" /><p>&#039;The Snowdrift: Let Your Voice Be Heard&#039; is Snow College&#039;s reputable college newspaper. The quality of our paper is astounding and is completely produced by students attending Snow College.</p><ul class="social clearfix"></ul></div>                </div><!-- #first .widget-area -->
                            
                                <div id="second" class="widget-area" role="complementary">
                    <div id="ti_image_banner-2" class="widget widget_ti_image_banner">            
            <a href="#" rel="nofollow" target="_blank">
            	<img src="http://www.snowcollegenews.com/wp-content/uploads/2013/10/Snow-square.jpg" alt="Ad" target="_blank" />
            </a>
            
	    </div><div id="ti-about-site-2" class="widget widget_ti-about-site"><h3>Follow Us</h3><img src="http://www.snowcollegenews.com/wp-content/uploads/2017/04/Screen-Shot-2017-04-17-at-2.53.58-PM.png" alt="" /><p>Snapchat: scsnowdrift
Instagram: @SnowCollege_Snowdrift</p><ul class="social social-center clearfix"><li><a href="https://twitter.com/SnowCollegeNews" aria-hidden="true" class="icon-twitter" target="_blank"></a></li><li><a href="https://www.facebook.com/pages/Snow-College-Snowdrift/532921896799164" aria-hidden="true" class="icon-facebook" target="_blank"></a></li></ul></div>                </div><!-- #second .widget-area -->
                            
                                <div id="third" class="widget-area" role="complementary">
                    <div id="text-2" class="widget widget_text"><h3>Have any article ideas? </h3>			<div class="textwidget"><p>Email them to snowdrift@snow.edu</p>
</div>
		</div>                </div><!-- #third .widget-area -->
                            </div><!-- #supplementary -->
	</div>        
        <div class="copyright">
            <div class="wrapper">
            	<div class="grids">
                    <div class="grid-10">
                        Copyright © 2014 Snowdrift. All Rights Reserved.                    </div>
                    <div class="grid-2">
                        <a href="#" class="back-top">Back to top <i class="icon-chevron-up"></i></a>
                    </div>
                </div>
            </div>
        </div>
            
    </footer><!-- #footer -->
    
    </div><!-- #inner-wrap -->
</div><!-- #outer-wrap -->
    
<link rel='stylesheet' id='author-bio-box-styles-css'  href='http://www.snowcollegenews.com/wp-content/plugins/author-bio-box/assets/css/author-bio-box.css?ver=3.3.1' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202107'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/themes/simplemag/js/jquery.flexslider-min.js?ver=2.1'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/themes/simplemag/js/jquery.caroufredsel.js?ver=6.2.0'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/themes/simplemag/js/jquery.touchSwipe.min.js?ver=1.3.3'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/themes/simplemag/js/jquery.assets.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/themes/simplemag/js/jquery.custom.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-includes/js/wp-embed.min.js?ver=5.3.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fsb = {"ajax":"https:\/\/www.snowcollegenews.com\/wp-admin\/admin-ajax.php","nonce":"2d58f085dc"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.snowcollegenews.com/wp-content/plugins/floating-social-bar/js/fsb.js?ver=1.1.7'></script>
<script async="async" type='text/javascript' src='http://www.snowcollegenews.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202107.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.9.1',blog:'59008607',post:'7075',tz:'-7',srv:'www.snowcollegenews.com'} ]);
	_stq.push([ 'clickTrackerInit', '59008607', '7075' ]);
</script>
</body>
</html>